I suppose the time had to come when when old 5d would start to have problems. Unfortuanately it’s happened while Kim and I were in the middle of a 2 week photo trip.

I was taking a series of of photos at St Michaels’s Mount in Cornwall. As usual for this type of thing, I set-up on my tripod and didn’t look through the view finder again until I had to recompose. The first hint that something was amiss was when I changed the exposure and the meter was telling me 25 seconds at f20, even though a few minutes earlier I was getting 2 seconds at f22. I checked the view finder and all I could see was black. My first thought was that the lens cap was on, completely forgetting that I had been shooting ok at f22. A couple of off/ons and hard reseting by taking the battery out didn’t help. So, I took the lens off and discovered that the mirror was hanging off. Fortunately for me I didn’t have the front of the camera tilted down otherwise it would probably have dropped out into the seaweed!

Broken Mirror on my 5d Mark I

I guess that the earlier shots had caused enough vibration to shake the mirror off its mounting. Whatever the cause, it looks like I’ll need to get it repaired. I think I’ll also get it converted to infra-red at the same time though. As it happens, I was intending to do this anyway once I replaced it with one of Canon’s soon (hopefully) to be released 1Ds Mark III or 5d Mark II replacements.

Fortunately, Kim still has an old 5d Mark I, so we’ll be taking a 150 mile detour as we travel between Cornwall and the Lake District to collect her old camera from home. In the meantime, I’ll be using my my iPhone (thanks to Dave et al for the suggestion). I guess on the plus side, this didn’t happen on our planned trip to Iceland!

About The Author

Related Posts

2 Responses